| Amiga CD32 – eine Wiederbelebung?

Ich habe vor vielen Jahren ein recht billig eine gebrauchte Amiga CD32-Konsole gekauft – damals um sie per Nullmodemkabel mit dem Amiga zu verbinden und so ein CD-ROM-laufwerk zu erhalten. Ein handvoll Spiele, ein Controller, das war’s schon.

Irgendwann wanderte sie mit vielem anderen alten Computerkram in den Keller – aus dem ich sie vor einer Weile wieder hervorgeholt habe. Nur leider springt sie nicht mehr an.

Hier will ich Infos und Links sammeln, damit möglichst viele von euch Ihre Konsole wieder ans laufen bekommen. Vielleicht mach ich dann auch ein Video davon und darüber.

Schließlich ist die CD32 ein toller Computer – die erste 32bit-Konsole, die erste mit CD-ROM-Laufwerk und ein Amiga. Mit einem Wenig beachteten Zusatzchip, der 3D-Spiele ermöglichte und damit fast ebenbürtig mit der viel später erschienenen ersten Playstation.

Außerdem bekommt man keinen günstigen Ersatz. Auf Ebay werden CD32 für 399€ angeboten.

Die Symptome

Die Power-LED geht an – bleibt aber auf der Helligkeit. Amiga-Kenner wissen, dass die Power-LED aber 2 Helligkeiten annimmt und damit verschiedene Betriebszustände anzeigt.

Die Drive-LED geht nicht an. Keine Reaktion vom Laufwerk.

Das Composite-Signal (Gelbe Cinch-Buchse) kommt, bleibt aber schwarz. Bei manchen Einschaltversuchen kommt allerdings ein weißer Bildschirm.

Reparaturansätze

1. Netzteil prüfen.

Voltmeter raus und gecheckt. Jep: +12V und +5V sind da, relativ genau, nicht schwankend. Augenscheinlich ist das Netzteil i.O. Wie es sich unter lasst verhält kann ich so nicht ermitteln, aber so schlimm kann es nicht sein. Also fehlanzeige hier

2. Hinweis: Kondensatoren prüfen

Funfact: bei der recht eiligen Herstellung der CD32 sind wohl bei ganzen Chargen Kondensatoren verpolt eingelötet worden. Die Kondensatoren sollen die Eingangsspannungen glätten – also haben die Konsolen mit dem Fehler trotzdem funktioniert, bis die Kondensatoren wegen der Verpolung platzten.

Hier ein Fall, in dem der Kondensatortausch geholfen hat: http://8bitplus.co.uk/projects/amiga-cd32-repairs/.  Auch hier waren die Kondensatoren falsch herum montiert, wie man auf den Bildern sieht.

Abseits dieser Information fehlt allerdings so ein bisschen ein Aussage darüber, wie herum sie denn richtig hineingehören. Ich habe mich an folgendem Video orientiert. Man sieht dort die originalen Kondensatoren verdreht und bei etwa 22:39 sieht man, dass die Beschriftung auf dem Board falsch ist. Später sieht man, dass er die neuen Kondensatoren andersherum wieder einlötet, also mit dem Minuspol Richtung Stromanschluss.

Meine Kondensatoren sahen gut aus und waren (meiner Meinung nach) nicht verpolt. Ich hab sie trotzdem ausgetauscht. Leider änderte sich nichts an den Symptomen.

Kickstart ROM ziehen

Der Tipp kam, (u.a. anderem hier) Möglicherweise hat das EPROM ja Kontaktschwierigkeiten. Obwohl eher ein Tipp aus der Kategorie „have you tried turning it off and on again?“ ist, ahe ich es probiert.

Links, & Forum-Threads:

http://www.amibay.com/showthread.php?4756-Help-save-a-sick-CD32

Amiga CD32 Repairs


http://www.amibay.com/showthread.php?90901-Amiga-hardware-repair-restoration-and-upgrade-service
Amibay-Amiga-repair-Guru hese aus Finnland: ist das der Typ aus dem Video? http://www.amibay.com/member.php?701-hese