2009-12-18 | flash10.1pre2 und Firefox auf Ubuntu 9.04

Ich habe ja letztens kurz geschrieben, wie man unter Ubuntu Flash 10.1pre1 installiert. Mit Opera funktioniert es auch ganz ordentlich, die CPU-Belastung beim Wiedergeben von Videos ist nur ein wenig höher. Von Hardwarebeschleunigung ist leider nicht viel zu spüren, was wohl an meiner nicht unterstützten GeForce 7600GS liegen wird. Gerüchteweise werden nur Mpdelle ab der 8000er Reihe unterstützt. Für einen Pointer zu einem auführlichen Dokument dazu wäre ich dankbar.

Nur unter Firefox funktionierte Flash dann nicht mehr. Obwohl ich den Firefox selten benutze, sollte auf meinem Rechner trotzdem alles funktionieren. Gestern ist dann noch die zweite Beta veröffentlicht worden. Zwei Gründe also, das Ganze noch einmal anzugehen.

In meiner — dank zahlreicher distribution-upgrades ziemlich verhunzten — Ubuntuinstallation gibt es es das Verzeichnis /usr/lib/firefox-addons. Der Installer mag dieses Verzeichnis nicht akzeptieren, also kopiert man manuell die libflashplayer.so in das dortige Plugin-Verzeichnis. Firefox vorher zu beenden erspart eventuellen Ärger.

$> tar -zxvf flashplayer10_1_p2_linux_121709.tar.gz
$> cd install_flash_player_10_linux
$> sudo cp libflashplayer.so /usr/lib/firefox-addons/plugins/

Fertig, danach funktioniert Flash auch wieder im Firefox und taucht auch unter Plugins im Addon-Manager auf. Ich habe auch noch eine Anleitung bei Ubuntugeek gefunden, die Hinweise gibt. Allerdings ist die dort beschriebene manuelle Methode nur dafür geeignet, den Flashplayer nur für einen Benutzer zu installieren. Wer Flash auf einem Rechner braucht, den er nicht administrieren darf, dem ist dort geholfen. Aber warum sollte man Beta-Software zum Probieren auf einem solchen System installieren wollen?

[Update] inzwischen hab ich die Specs gefunden. Linux wird vorerst keine Hardwarebeschleunigung bekommen, da es dafür angeblich keine API gibt. Nunja.

Die Kommentarfunktion ist geschlossen.